Cookie-Plugin funktioniert nicht

  • Hallihallo,


    dass die DSGVO mir Panik bereitet, wisst ihr sicher schon längst.

    Dass man eigentlich einen Hinweis braucht, dass die Seite Cookies verwendet, weiß ich auch ... Nur: Die ganzen Plugins, die diesen Hinweis einblenden, wollen auf Habutschu einfach nicht funktionieren.


    Kann mir jemand sagen, woran das liegen könnte, oder mir verraten, was ich dagegen tun kann?

  • Moin moin,


    also, erstmal: eigentlich braucht es dieses Plugin mit dem Cookie-Hinweis derzeit noch gar nicht. Das soll erst 2019 geregelt werden. Bis dahin musst du diesen Hinweis nur anzeigen, falls du Google AdSense verwendest (tust du ja nicht).


    Wenn ich deinen Blog aufrufe, spuckt die Konsole einen Fehler aus ("Uncaught TypeError: $ is not a function at app.js?ver=1.0:2") - da fliegt jQuery auf die Nase. Da müsste etwas in deinem Theme (woher die app.js kommt) umgeschrieben werden... kann sein, dass das die Ursache ist, kann davon aber auch unabhängig sein.


    Magst du mal auf einem Testblog ein anderes Layout einstellen und gucken, ob es mit dem Plugin dann funktioniert? Welches Plugin verwendest du dafür denn?



    Liebe Grüße

  • Hmm, strange... ich hab deine Seite auch mal im Inkognito-Modus aufgerufen um auszuschließen, dass ich dem Ding vielleicht irgendwann schon mal zugestimmt hatte und es deswegen nicht mehr sehe.


    Zwei Vermutungen hätte ich noch:


    1. Steht in der footer.php von deinem Theme das hier drin? Da hängen sich viele Plugins rein, d.h. wenn das fehlt, funktionieren die Plugins nicht richtig:
      <?php wp_footer(); ?>
    2. Hast du eventuell ein Caching-Plugin installiert, bei dem du mal den Cache deines Blogs leeren kannst? Eventuell hängen da die alten Dateien fest?